Панченко Людмила Алексеевна


Общие сведения Формулы, имена и массивыРабота с формулами



страница4/6
Дата09.08.2019
Размер1.19 Mb.
#127830
ТипМетодические указания
1   2   3   4   5   6

Общие сведения

Формулы, имена и массивыРабота с формулами


Вычисления в таблицах выполняются с помощью формул. Формула может состоять из математических операторов, значений, ссылок на ячейку и имена функций. Результатом выполнения формулы есть некоторое новое значение, содержащееся в ячейке, где находится формула. Формула начинается со знака равенства «=«. В формуле могут использоваться арифметические операторы + - * / Порядок вычислений определяется обычными математическими законами.

Примеры формул: =(А4+В8)*С6, =F7*С14+B12.



Константы – текстовые или числовые значения, которые вводятся в ячейку и не могут изменяться во время вычислений.

Ссылка на ячейку или группу ячеек – способ, которым указывается конкретная ячейка или несколько ячеек. Ссылка на отдельную ячейку – ее координаты. Значение пустой ячейки равно нулю.

Ссылки на ячейки бывают двух типов:



относительные – ячейки обозначаются относительным смещением от ячейки с формулой (например:F7).

абсолютные – ячейки обозначаются координатами ячеек в сочетании со знаком $ (например:$F$7).

Комбинация предыдущих типов (например:F$7).

При копировании формул относительные ссылки изменяются на размер перемещения.

Для обращения к группе ячеек используются специальные символы:



: (двоеточие) – формирует обращение к блоку ячеек. Через двоеточие указывается левая верхняя и правая нижняя ячейки блока. Например: С4:D6 – обращение к ячейкам С4, С5, С6, D4, D5, D6.

; (точка с запятой) – обозначает объединение ячеек. Например, D2:D4;D6:D8 – обращение к ячейкам D2, D3, D4, D6, D7, D8.

Для ввода формулы в ячейку следует ввести знак '=' и формулу для вычисления. После нажатия клавиши Enter в ячейке появится результат вычисления. При выделении ячейки, содержащей формулу, формула появляется в строке редактирования.


Функции


Функциямив Microsoft Excel называют объединения нескольких вычислительных операций для решения определенной задачи. Функции в Microsoft Excel представляют собой формулы, которые имеют один или несколько аргументов. В качестве аргументов указываются числовые значения или адреса ячеек.

Например:



=СУММ(А5:А9)сумма ячеекА5, А6, А7, А8, А9;

=СРЗНАЧ(G4:G6)среднее значение ячеекG4, G5, G6.

Функции могут входить одна в другую, например:



=СУММ(F1:F20)ОКРУГЛ(СРЗНАЧ(H4:H8);2);

Для введения функции в ячейку необходимо:



  • выделить ячейку для формулы;

  • вызывать вкладку Формулы с помощью команды Вставить функциювызвать Мастер функций

Мастер функций




  • в диалоговом окне Мастер функций выбрать тип функции в поле Категория, затем функцию в списке Выберите функцию;

  • щелкнуть кнопку ОК;

Задание 1. Вычисления по формулам

Выполните вычисления по следующим формулам:



A= , B= , C= ,

считая заданными величины x, y, zсоответственно в ячейках A3, B3 и C3





Методические указания.

Введите в ячейки A3, B3 и C3 конкретные значения переменных, например 1,2, 3,0 1.5 и присвоим этим ячейкам соответственно имена X, Y, Z . Для присвоения имен ячейкам используйте панель Формулы вкладку Определенные именакоманду Присвоить имя. В появившемся окне Создание имени (рис) задать Имя (переменную) и Диапазон (удалить предлагаемый диапазон и щелкнуть по нужной ячейке) и нажать OK.

В ячейки A5, A6 и A7 введите поясняющий текст, а в ячейки B5, B6 и B7 соответствующие формулы. Например, для вычисления первого значения можно ввести формулу =4+3*X+2*X^2+X^3. Однако, лучше провести вычисления по схеме Горнера, которая позволяет уменьшить число выполняемых операций. В этом случае формула примет вид =((X+2)*X+3)*X+4. Предложенные формулы используют в качестве операндов, созданные имена, что делает их похожими на соответствующие математически формулы. При необходимости, в формулах также можно использовать и ссылки на ячейки рабочей таблицы. В этом случае нужная формула имела бы вид:

= (A3+2)*A3+3)*A3+4.




Задание 2.Восточный календарь.

Составитьэлектронную таблицу, определяющую по дате название года по восточному календарю.



Методические указания.

Составьте таблицу и заполните ее информацией.






A
B

C

1

Дата рождения

14.02.2001




2




0

«обезъяны»

3




1

«петуха»

4




2

«собаки»

5




3

«свиньи»

6




4

«крысы»

7




5

«быка»

8




6

«тигра»

9




7

«кролика»

10




8

«дракона»

11




9

«змеи»

12




10

«лошади»

13




11

«козы»

14

Вы родились в год

«быка»



В клетку B1 введитедату рождения, например, 14.02.2001, в клетку B14, в которой должно быть получено название года по восточному календарю, запишите формулу:



=ВПР(ОСТАТ(ГОД(B1);12);B2:C13;2)

Диаграммы. Поиск информации в таблице

Цель: освоить основные операции по созданию, редактированию и оформлению электронных таблиц, построению графиков и диаграмм.

Общие сведения

Каталог: files -> main -> documents -> 2018
2018 -> Реконструкция электрооборудования трансформаторной подстанции, ао «соатэ» Мелихов Дмитрий Андреевич, студент 4-го курса
2018 -> Менглибаев Алишер Менглиярович врач первой квалификационной категории гбу «Макушинская црб». Данное учебное пособие
2018 -> «Сестринский уход при желчнокаменной болезни»
2018 -> Викторина по учебной дисциплине иностранный язык «Познание мира через языки. 26 сентября День европейских языков»
2018 -> Ремонт электрооборудования дсп-6 ээрц, ао «озмм» Ястремский Вадим Дмитриевич, студент 4-го курса
2018 -> Ремонт электрооборудования поворотного стола для транспортировки заготовок, эспц ао
2018 -> Почему взрываются аккумуляторы
2018 -> Здоровое питание
2018 -> Рабочая программа учебной дисциплины


Поделитесь с Вашими друзьями:
1   2   3   4   5   6




База данных защищена авторским правом ©vossta.ru 2022
обратиться к администрации

    Главная страница